Home > Luminaires > Fluorescent Luminaires > Surface Fluorescent Luminaires
Click to view full size image

Old 3x40w Switchstarts In Antique Shop

Shop near me; rather than remove the 4 rows of old lights, 3 new rows have been installed.

Look_What_I_Found_Today.JPG Thorns1.JPG Antique2.JPG Antique1.JPG UV_CAGE.JPG
File information
Filename:Antique2.JPG
Album name:Surface Fluorescent Luminaires
Manufacturer:Unknown
Power Consumption:3x40w
Working Voltage:240v 50Hz
Overall Length:4'
Burn Position :Horizontal
Comments:This is a very old building and it appears as though it was easier to install new rows of fittings and leave the old ones where they are. A few still had tubes and starters however none were connected. New fittings are 2x36w switch start Thorn Cadet'.
Date / Code:Probably 1940's/1950's
Country Of Origin:Australia
Filesize:89 KiB
Date added:May 07, 2012
Dimensions:723 x 1024 pixels
Displayed:75 times
URL:https://allthingslighting.co.uk/atl/displayimage.php?pid=7595
Favourites:Add to Favourites

Comment 1 to 7 of 7
Page: 1

Kev   [May 07, 2012 at 03:49 PM]
I wonder why they didnt just do the proper thing and repair the old lights. Its probably easier than installing all those new ones
Paul   [May 07, 2012 at 03:50 PM]
Perhaps the sparkies weren't techincally competent enough to, unlike someone I know! Wink
Alan_M   [May 07, 2012 at 11:07 PM]
I'm not sure about the history of these as I've only just found the shop. All I can think of is that they were probably costing too much to keep running as in ballasts & cabling may have been failing. Of course, if it'd been me I would've spent the effort to revamp these with new gear, cabling, lampholders etc all of which are still available. Do they make 3x36w HF ballasts (no, just kidding...)
Kev   [May 07, 2012 at 11:26 PM]
HA HA HA Yes they do actually! Tridonic PC336HF Pro. Crap though lol
Linear_SLI   [May 08, 2012 at 04:02 PM]
These would be a nice retrieve item?
Kev   [Apr 03, 2014 at 08:03 PM]
See this pix from time to time would of loved to restore these! Cool
Paul   [Apr 03, 2014 at 11:25 PM]
Looks like one of the new fittings has failed already!

Comment 1 to 7 of 7
Page: 1

Add your comment
Anonymous comments are not allowed here. Log in to post your comment